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Mobile	and	desktop	web	application	built	for	
collecting	coastal	usage	data	across	a	variety	of	

categories.	
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Coastal	Use	Reporting	Suite	
Overview	of	the	Application	
	

The	Crowdsource	Reporter	Application	is	an	ESRI	Web	Application	template	that	
allows	for	either	authorized	or	anonymous	submission	of	GIS	data	in	the	form	of	points,	
lines,	or	polygon	geometry.	Data	collected	through	the	application	can	be	utilized	either	
within	the	ArcGIS	Online	Portal	for	quick	geoprocessing	or	downloaded	and	viewed	in	
ArcMap	for	further	analysis.	

Main	level	of	the	application,	containing	existing	reports	and	category	layers	in	the	right	hand	pane.	
	

	
The	Web	Application,	Web	Maps,	and	

Hosted	Feature	Layers	are	all	by	default	
located	in	a	User’s	content	in	an	ArcGIS	Online	
Organization.	The	functionality	of	the	
Reporter	Application	is	achieved	through	the	
creation	of	a	Group	and	by	sharing	all	content	
with	this	Group.	

	
Sharing	and	Editing	permissions	can	

be	configured	to	allow	for	either	a	single	user,	
multiple	users	in	an	organization,	or	public	
access	to	the	data	layers	used	in	the	
application.	The	layers	used	in	the	application	
can	be	added	to	other	Maps	and	Applications	
and	downloaded	to	perform	local	
manipulation	of	the	reports.		

The	group	created	to	house	the	App,	Maps,	and	Layers	
used	for	the	Reporter.	
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Coastal	Use	Reporting	Suite	
Procedure	

	
	 Many	of	the	steps	required	to	set	up	and	configure	a	functioning	Crowdsource	

Reporter	Web	Application	are	interchangeable.	The	following	is	a	brief	overview	of	what	is	

necessary	to	have	created,	configured,	shared,	and	published	to	obtain	the	functionality	

seen	in	the	existing	CURS	application.		
	
1)	Create	and	configure	Geodatabases	for	each	category	of	submission	(ArcMap)	

• Fields	that	have	submission	type	other	than	raw	text	input,	numerical	entry,	or	a	date	
require	Domains	to	limit	possible	responses.	

• A	text	field	in	the	application	with	drop	down	menus	requires	a	text	domain	type	with	
Coded	Values.	

o These	coded	values	become	the	selectable	items	in	the	application	via	drop	down	
menu.		

• A	numerical	field	in	the	application	will	have	‘+’	and	‘-‘	signs,	imposing	a	valid	range	for	
entries	requires	a	numerical	(Short	or	Long	Integer,	Double,	or	Float)	domain	with	a	Range	
domain	type.	

o Maximum	and	minimum	allowable	submissions	are	designated	via	this	range.	
• Date	fields	do	not	require	a	domain	for	functionality,	but	imposing	a	date	rang	limit	does.		

o Hidden	date	fields	proved	tricky,	see	‘Quirks’	for	further	details	
	
2)	Create	and	Configure	Feature	Classes	within	a	Geodatabase	(ArcMap)	

• Designate	the	feature	geometry,	coordinate	system,	and	fields	that	will	be	used	in	the	
Hosted	Feature	Layer	contained	in	Web	Maps	

• Allowing	or	rejecting	submissions	with	null	values	is	decided	with	layer	properties	
	
3)	Publish	these	Feature	Classes	to	the	ArcGIS	Online	Organization	(ArcMAP)	

• Capabilities,	descriptions,	and	sharing	permissions	are	initially	configured	during	
publishing	

• Designating	hidden	fields	is	accomplished	through	this	process	and	layer	configuration	
	

4)	Create	a	Group	that	will	‘contain’	all	of	the	content	(ArcGIS	Online)	

• The	application	and	all	of	the	Web	Maps	and	Hosted	Feature	Layers	need	to	be	shared	with	
this	group.	

• The	content	created	for	the	application	is	found	under	the	‘My	Content’	tab	in	ArcGIS	
Online	and	stored	there.		

• Sharing	with	this	group	simply	makes	a	link	between	all	of	the	different	files	necessary	for	
this	particular	ESRI	application.		

	

5)	Create	Web	Maps	for	each	category	of	submission	and	add	the	Layers	(ArcGIS	Online)	

• One	map	can	contain	multiple	layers	
• Each	map	shows	as	a	major	heading	in	the	application,	and	each	layer	shows	as	a	

subheading	
	

6)	Create	a	single	Web	Application	with	a	Crowdsource	Reporter	Template	(ArcGIS	Online)	

• Aesthetic	configuration	and	verification	of	proper	setup	follows	creation	of	the	application	
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Coastal	Use	Reporting	Suite	
Geodatabase	Configuration	
	

Key	to	the	functionality	of	the	reported	is	the	creation	of	Geodatabases	(GDB)	and	
the	configurations	of	Domains	within.	A	reporting	application	can	be	created	without	this	
backend	architecture,	but	it	will	not	drop	down,	range,	or	default	field	value	capabilities.	
Coded	values	or	Ranges	used	in	the	domain	allow	for	the	creation	of	a	drop	down	list	of	
possible	answers	or	a	hard	limited	range	for	numerical	values	that	will	cause	the	report	
submission	to	fail	if	not	followed.	In	addition,	the	ability	to	reject	null	values	from	a	
submission	essentially	makes	the	field	required	for	submission.		

	
	 For	this	particular	application,	a	discrete	geodatabase	for	
each	category	of	submission	is	required.	Although	many	of	the	same	
questions	appear	for	different	submission	categories,	the	values	
available	for	selection	in	the	drop	down	menus	changes.	This	
requires	unique	domains	to	be	configured	for	each	category,	while	
each	layer	in	the	Geodatabase	will	exhibit	the	same	properties.	Each	
category	in	this	application	contains	two	layers	for	possible	
submission,	a	point	and	polygon	layer.	The	name	of	these	layers	is	
fully	descriptive,	while	the	alias	is	simplified	to	prevent	redundancy	
in	the	application.			
	

	
	 Once	a	Geodatabase	is	created,	the	
Domains	tab	is	accessed	by	right-clicking	
the	GDB	in	Catalog	pane	and	selecting	the	
properties	option	in	the	dropdown.	
	
	 From	here,	Domains	are	created	and	
given	a	brief	description	(only	visible	in	
ArcMap).	For	drop	down	menus,	the	Field	
Type	will	be	‘Text’	and	the	Domain	Type	is	
‘Coded	Values.’	A	Code	is	created,	and	the	
description	thereof	is	what	will	appear	in	
the	Application	drop	down	menu	and	fill	
the	field	in	the	created	feature.			
	
	 For	numerical	values,	‘Short	Integer’	
is	selected	as	the	Field	Type,	‘Range’	for	the	
Domain	Type,	and	Minimum	and	Maximum	
values	input	as	needed.		
	
	 Date	fields	do	not	require	a	domain,	
as	simply	declaring	the	field	as	‘Date’	when	
creating	the	layer	will	default	to	a	‘Month	
Day,	Year’	format	in	the	application	that	
fills	with	the	current	date.		
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Coastal	Use	Reporting	Suite	
Layer	Configuration	
	
	 Layers	contained	within	a	GDB	inherit	Domains	and	Coded	Values,	as	well	as	any	
other	default	setting	present	in	a	Layer	Template	associated	with	the	GDB.	A	separate	layer	
is	needed	for	each	topic	and	feature	type	required	for	the	reporter.	For	the	CURS	
application,	there	are	six	categories	each	with	two	feature	types	available	for	submission.		
	

	 Create	a	new	layer	by	right	clicking	on	the	GDB	
and	selecting	New	->	Feature	Class.		
	
	 Give	it	a	descritptive	name,	and	an	alias	that	
describes	the	geometry	type.	The	alias	will	appear	in	
the	application	after	the	Web	Map	name	in	the	
following	format:	“WebMap	Title	–	Layer	Alias.”		
	
	
	
	

	 	
	 Next,	select	the	coordinate	system	that	
will	be	applied	to	any	submissions	on	this	layer.	
The	projected	coordinate	system	used	in	existing	
layers	is	“NAD	1983	UTM	Zone	17.”	
	 	
	 Fields	can	be	added	either	while	the	layer	is	being	created	or	after	the	fact.	If	a	layer	with	
similar	fields	already	exists,	these	fields	can	be	applied	to	the	new	feature	class	by	clicking	import	
at	the	appropriate	prompt	and	selecting	the	existing	feature	class	with	desirable	fields.		
	

	
	 This	proved	most	
useful	when	creating	
additional	layers	within	a	
category,	as	the	only	
difference	between	them	is	
feature	geometry.	For	different	
categories,	it	was	found	to	be	
faster	to	add	fields	from	
scratch	rather	than	try	and	
edit	existing	fields.		
	

	
	 With	a	field	created,	designate	
the	data	type,	provide	an	alias	that	will	
appear	as	the	question	in	the	
application,	and	select	the	appropriate	
domain	for	drop	down	answers	or	
numerical	range.	Provide	a	default	
value	if	desired	(a	hidden	layer	deafult	
shown	right).		
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Coastal	Use	Reporting	Suite	
Hidden	Fields	and	Null	Value	Acceptance	
	
Although	not	a	front-end	configurable	aspect	of	the	Crowdsource	reporter	application,	it	is	
possible	to	designate	certain	fields	as	‘Read-Only’	and	have	them	hidden	from	user	view	in	
the	reporting	pane.	If	a	default	value	is	defined	for	these	fields,	they	will	automatically	be	
completed	when	a	report	is	submitted.	In	addition,	the	ability	to	only	accept	a	report	upon	
completion	of	certain	fields	is	possible	by	changing	the	behavior	of	fields	submitted	with	no	
value	entered	(blank	or	Null).	
	

To	make	a	field	required	for	successful	submission,	it	
must	not	accept	null	values.	This	setting	is	configured	through	
the	layer	properties	menu	accessible	from	the	Catalog	pane.	
Left	click	the	layer	name	and	select	Properties.		
	
Under	the	Fields	Tab	in	the	properties	pane,	select	a	field	
name	and	change	the	setting	to	‘No’	under	Allow	NULL	Values.	
To	set	a	default	
value,	enter	the	
number	or	text	in	
the	Default	Value	
text	box.		

	
To	configure	a	field	as	hidden	in	the	report	submission	

pane,	access	the	Layer	properties	menu	from	the	Table	of	
Contents	in	ArcMap	by	left	clicking	the	layer	name	and	
selecting	Properties.	Note	that	this	is	a	different	menu	than	
previously	accessed.		

	
Under	the	Fields	Tab,	select	a	field	name	or	alias	and	

change	the	Read-Only	property	to	‘Yes’	before	clicking	Apply.	
Repeat	this	action	for	all	fields	that	will	be	hidden	from	the	
user’s	view	in	the	application.		
	
	 When	finished,	publish	the	category	layers	by	clicking	
File	->	Share	As	->	Service,	Publish	a	Service.	All	of	the	layers	
within	the	category	should	be	in	the	map	frame	and	visible	in	
the	Table	of	Contents	before	publishing.		

The	second	step	to	ensuring	these	
fields	remain	visible	but	do	not	disrupt	
report	submission	is	to	change	the	Read-
Only	property	to	‘No’	and	republish	the	
layers,	this	time	by	selecting	File	->	Share	
As	->	Service,	Overwrite	an	existing	service	
and	making	sure	that	you	are	overwriting	
the	same	category	that	was	previously	
published	as	a	new	service.		
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Coastal	Use	Reporting	Suite	
Hosted	Feature	Layers	
	

Once	the	layers	have	been	created	and	configured,	they	must	be	published	to	an	
ArcGIS	Online	account	as	Services	to	act	as	Hosted	Feature	Layers	that	can	be	added	to	Web	
Maps.		

	
	 Within	ArcMap,	select	File	->	Sign	In	and	provide	the	login	

credentials	of	an	account	with	publishing	or	administrative	

permissions	tied	to	the	ArcGIS	Online	organization.		

	

To	publish	a	layer,	select	File	->	Share	As	->	Service.	

	 	

	 	 	

	
	
 
 
	

	
	

	

	

	 Next,	select	publish	a	service.	Keep	in	mind	

when	publishing,	fields	that	are	to	be	hidden	from	the	

user	should	be	set	as	‘Read	Only’	to	‘Yes’	as	mentioned	

in	the	previous	section.	This	is	then	changed	to	‘No’	

and	the	service	re-uploaded	with	‘Overwrite	an	

Existing	Service.’	

	

	

	 This	is	discussed	further	in	‘Quirks.’	

	

	

	

	

	

	

	 The	publishing	location	should	default	to	the	

organization	tied	to	the	account.	The	service	name	

should	be	descriptive,	as	it	has	no	bearing	on	what	

will	appear	in	the	application.		

	

	

	

	

	

Setting	certain	capabilities	and	the	sharing	permissions	of	the	Hosted	Feature	Layer	
can	be	accomplished	directly	through	ArcGIS	Online,	however	since	these	options	are	also	
available	during	publishing	it	is	recommended	to	publish	with	these	settings	configured.	
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Coastal	Use	Reporting	Suite	
Hosted	Feature	Layers	
	
Note	that	the	Item	Description	fields	‘Tags’	and	‘Summary’	must	be	filled	out	before	the	
layer	can	be	published.		

	
	
The	default	behavior	of	a	published	
feature	layer	is	‘Tiled	Mapping’	–	change	
this	to	‘Feature	Access’	by	using	the	tick	
boxes.	This	option	must	be	selected	
during	publishing;	otherwise	ArcGIS	
Credits	will	be	used	to	create	a	Tile	
Cache	unnecessarily.		
	

	
	
	
	 The	specific	functions	
available	to	the	layer	can	be	changed	
through	ArcGIS	Online,	but	simply	
selecting	‘Create’	through	this	menu	
takes	care	of	most	of	the	
configuration	necessary.		
	
	
	

	
For	the	Reporter	application	to	function	correctly,	all	
content	used	(the	application,	all	maps,	and	all	layers)	
must	be	publically	shared	(‘Everyone’)	and	shared	
with	the	group	that	was	created	to	house	all	content.		
	
These	permissions	can	also	be	edited	through	ArcGIS	
online.		
	
If	you	see	the	error	‘Group	empty	or	not	properly	
configured’	when	opening	the	application	and	are	
greeted	with	a	blank	main	map	pane,	it	is	most	likely	a	
sharing	permission	error.		
	

	
Finally,	select	‘Publish’	and	wait	for	ArcMap	to	finish	
running	the	process.	Warnings	during	publishing	will	
occur	but	do	not	inhibit	successful	publishing	of	the	
layer.			
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Coastal	Use	Reporting	Suite	
Group	Configuration	
	
Central	to	the	mechanisms	required	for	a	functioning	Crowdsource	Reporter	application	is	
the	existence	of	a	Group	that	contains	all	of	the	content	used	in	the	application.	All	items	
are	shared	with	this	group,	and	the	Group	itself	is	shared	publically.		
	

	 The	group	shown	to	the	left	is	fully	
configured,	with	the	three	main	types	of	content	
displayed	(Hosted	Layer,	Web	Map,	and	the	
Crowdsource	Web	Application).	The	Service	
Definition	file	that	is	created	when	a	layer	is	
published	from	ArcMap	to	ArcGIS	Online	has	also	
been	shared	with	this	group	(although	it	has	not	
been	confirmed	this	is	necessary).		
	
	 To	create	a	new	group	that	will	be	the	
target	of	the	Crowdsource	Reporter	content,	log	
in	to	the	ArcGIS	Online	portal	for	your	
organization,	click	the	‘Group’	tab	at	the	top	bar	
and	select	‘Create	a	Group’	in	the	upper	left	hand	
corner.		
	

	 	
	 	

	
	

	
	 Configure	the	new	Group	by	giving	it	a	
name,	summary,	description	and	tags.	The	group	
image	can	be	selected	from	a	thumbnail	or	icon	
relevant	to	the	group.		

	
	
	
	
	
	

	
	
	
	 Change	the	Group’s	sharing	permission	to	best	
suit	the	needs	of	contributing	members	and	make	
sure	it	is	shared	with	the	Public	before	saving.		
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Coastal	Use	Reporting	Suite	
Application	Configuration	
	
The	Crowdsource	Reporter	is	part	of	a	suite	of	template	Web	Applications	created	by	ESRI	
to	make	collecting	data	from	the	public	or	within	an	organization	easy	to	set	up	and	use.		
	

	 Make	a	new	application	by	
navigating	to	the	My	Content	tab	in	
ArcGIS	Online,	and	selecting	Create	->	
App	->	Using	a	Template.	There	are	
many	options	for	preconfigured	web	
applications	available;	the	Crowdsource	
Reporter	can	be	found	under	the	
‘Collect/Edit	Data’	category.		
	

	
	 	
	
	
	 Find	the	correct	template,	and	select	‘Create	
Web	App’	before	filling	in	information	for	the	title,	
tags,	and	summary.	You	will	then	be	directed	to	
the	configuration	page	for	the	newly	created	app	
wherein	you	can	change	the	aesthetics	and	front	
end	functionality	of	the	application.		
	
	
	
	

 
	 	
	
	 The	first	option	for	configuration	is	
selecting	the	Group	that	the	application	will	be	
associated	with.	Click	this	button,	and	then	
choose	the	appropriate	group	either	from	the	
‘My	Content’	filter	or	the	organization	under	
which	the	Group	exists	if	not	the	creator	of	the	
Group.		
	
	
	
	

	
Further	configuration	can	be	completed	now	or	at	a	later	time	after	the	rest	of	the	needed	
content	has	been	uploaded	or	created.	The	options	used	for	the	existing	Coastal	Use	
Reporting	Suite	will	be	covered	in	the	Aesthetics	section.		
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Coastal	Use	Reporting	Suite	
Web	Maps	
	
Web	Maps	are	created	to	contain	each	category	of	submission	topic	and	display	the	data	
collected	therein.	Each	map	will	appear	as	a	major	heading	in	the	reporter	application,	and	
can	host	multiple	layers	(in	this	case	a	single	category	with	two	layers	–	point	and	polygon	
submissions).		
	

	 Under	the	My	Content	tab	in	ArcGIS	Online,	
select	Create	->	Map	and	enter	the	Title,	Tags,	and	
Summary	information	for	the	new	web	map.		
	
	 Afterwards,	you	will	be	directed	to	the	new	
blank	web	map.	From	here,	you	can	configure	the	
basemap	and	content	that	will	be	shown	(layers)	
when	a	user	views	this	map.	The	extent	of	the	map	
will	be	set	when	the	map	is	saved,	or	can	be	directly	
edited	from	the	Settings	tab	on	the	Item	Details	page.		

	
	
	 Add	a	Hosted	Feature	layer	that	was	
previously	published	via	ArcMap	by	clicking	
Add	->	Search	for	Layers.	The	layer	can	be	
found	either	in	‘My	Content’	if	this	is	the	
authoring	account,	otherwise	it	can	be	found	in	
‘My	Organization.’	
	
	 The	single	layer	title	should	contain	
both	the	point	and	polygon	classes	that	were	
created	in	ArcMap,	verify	this	by	clicking	‘Add’	
and	then	‘Done	Adding	Layers’	before	checking	
in	the	Content	pane	on	the	left	and	side.		
	 	
	 Save	the	map,	and	then	either	click	
‘Share’	while	still	in	the	map	viewer	or	select	the	same	option	from	the	Item	Details	page.	Ensure	
that	the	Map	is	shared	with	‘Everyone’	as	well	as	the	Group	that	was	created	for	the	reporter	
application.		
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Coastal	Use	Reporting	Suite	
Aesthetics		

	

The	majority	of	the	visual	settings	of	the	Reporting	Application	are	changed	via	the	‘App	

Settings’	tab	accessed	from	the	‘Configure	App’	page.	The	color	scheme,	logos,	splash	page	

image	and	text,	description	settings,	and	help	page	content	are	all	controlled	through	this	

page.			

	
	 From	the	‘My	Content’	tab	in	ArcGIS	Online,	click	the	title	of	the	Web	App	to	view	the	Item	
Details	page.	From	here,	the	Configure	App	button	will	direct	you	to	the	page	that	was	first	
presented	when	creating	the	application.		
	
The	‘App	Settings’	tab	allows	for	the	selection	of	an	associated	group,	the	retitling	of	the	
application,	including	subtitle	text	on	the	splash	page,	as	well	as	the	configuration	of	images	used	
in	the	app.		
	
The	existing	application	is	titled		
	
	 ‘Recreational	Usage	Reporter’		
	
with	a	subtitle	(limited	to	36	characters)	reading	
	
	 	‘The	Nature	Conservancy	and	Georgia	DNR	reporting	application.’	
	

The	splash	screen	image	is	hosted	at	geospatial.gatech.edu/CURS/PierSmall.png	and	included	
with	this	document	for	re-uploading	and	hosting.	The	image	can	be	any	size,	but	is	recommended	
to	be	640	x	960	pixels	to	show	properly	on	small	mobile	devices.		
	
The	logo	used	in	the	upper	left	hand	corner	of	the	application	on	desktop,	and	the	top	bar	on	
mobile	is	hosted	at	www.nature.org/cs/groups/webasset/documents/webasset/logo-
nature-notagline.png	 	

	

The	application	color	can	be	chosen	from	the	palette	provided	(currently	#4C7300)	or	entered	as	
a	hexadecimal	html	color	code.	
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Coastal	Use	Reporting	Suite	
Aesthetics		
	
Under	the	‘Map	Settings’	tab,	the	only	change	made	to	default	values	was	selecting	‘Description’	
as	the	element	shown	for	each	Web	Map,	found	under	the	‘Map	Information’	subheading.	This	
option	shows	a	tagline	of	Description	and	the	text	entered	in	the	Web	Map	Item	Details	page	when	
the	information	icon	is	clicked	for	a	category	title	in	the	reporting	application.		
	
To	allow	or	disallow	users	to	sign	in	via	social	media,	change	the	tick	boxes	under	‘Access	Settings’	
–	currently	only	anonymous	access	is	allowed	for	the	application.		
	
The	help	page	is	configured	through	‘Help	Widget	Settings’	with	the	content	as	follows:	
	
‘The	Recreational	Reporter	application	presents	maps	that	can	be	used	to	report	an	activity	or	
observation.	Users	can	submit	new	reports	and	review	existing	reports.		
	
To	submit	a	report,	click	on	the	layer	group	heading	that	best	describes	the	activity	you	wish	to	
provide	information	about.		
	
Next,	either	record	a	single	point	or	draw	a	shape	to	record	an	area	by	selecting	the	layer	
labelled	either	'Locations'	or	'Areas'	respectively	-	this	will	bring	up	all	of	the	existing	reports	
under	that	layer.	At	the	bottom	of	the	screen,	click	'Submit	a	report.'	
	
Finally,	fill	out	the	information	in	the	form	that	you	wish	to	provide	and	then	either	click	on	the	
mini	map	to	add	a	point	or	to	start	drawing	a	shape.	Double	click	to	end	the	shape	and	the	tool	will	
automatically	connect	the	lines	to	create	a	closed	polygon.	Clicking	'Report	It'	will	save	your	
report.	
	
Watch	this	Tutorial	Video	if	you	need	further	help	getting	started.”		
	
The	link	directs	users	to	a	story	map	tutorial	hosted	at	geospatial.gatech.edu/curs/tutorial/	
	
When	finished	configuring	this	side	of	the	application	aesthetics,	click	Save	at	the	bottom	of	the	
page.		
	
The	images	that	appear	for	each	category	title	in	the	application	are	controlled	by	setting	
thumbnails	for	the	Web	Maps	themselves	and	are	also	included	with	this	document.	From	the	Web	
Map	Item	Details	page,	select	Edit	Thumbnail	and	choose	a	file	from	your	computer	to	upload.			
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Coastal	Use	Reporting	Suite	
Data	Preservation	
	
When	overwriting	existing	hosted	feature	layer	services,	any	data	that	currently	exists	in	
the	layer	(previous	reports)	will	be	lost.	To	ensure	that	reports	are	cataloged	and	kept	for	
review,	it	is	advisable	to	download	the	layer	from	ArcGIS	Online	and	merge	it	was	a	master	
file	maintained	locally	to	prevent	the	loss	of	any	reports.			
	
	 From	the	desired	layer’s	Item	Details	page,	select	Export	Data	->	Export	to	Shapefile	(or	
other	type	file	if	needed).	The	layer	will	be	then	be	packaged	and	exported	as	the	selected	file	type	
and	hosted	in	the	selected	folder	under	in	the	user’s	My	Content	tab.	From	here,	the	layer	can	be	
downloaded	and	opened	locally	for	further	geoprocessing	and	data	management	tasks.		
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Quirks	
	
ESRI	continually	updates	not	only	their	selection	of	premade	web	application	and	map	
templates	and	the	graphic	user	interface	that	controls	them,	but	also	tweaks	back	end	
behavior	quite	frequently.	Changelogs	are	often	included	with	updates,	and	the	most	
current	information	regarding	an	applications	behavior	can	be	found	either	on	the	ESRI	
website	or	in	threads	on	the	GitHub	page	for	the	application.		
	
	 ArcGIS	online	has	received	a	rather	extensive	makeover	since	this	application	was	first	
built.	Navigating	through	the	setting	necessary	to	configure	the	crowdsource	reporter	application	
is	accomplished	through	a	different	workflow,	but	all	of	the	same	options	and	configuration	
settings	still	exist	in	addition	to	some	new	options	and	features.		
	
	 The	most	important	aspect	of	the	Crowdsource	Reporter	is	the	sharing	hierarchy	that	must	
be	built	to	properly	allow	for	editing	of	the	hosted	feature	layers	by	anonymous	users.	If	sharing	
settings	have	been	confirmed	correct	and	the	application	is	still	not	responding	as	required,	check	
the	editing	permissions	for	the	feature	layers.	Although	these	should	be	properly	configured	when	
the	layer	was	uploaded,	they	can	be	rectified	if	incorrect	by	navigating	to	the	layer’s	Item	Details	
page,	and	selecting	the	‘Settings’	tab.	Scroll	down	to	the	subheading	‘Feature	Layer	(Hosted)	
Settings’	and	ensure	that	Editing	is	Enabled.		
	
	
 
 
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	 The	type	of	editing	permissions	and	level	of	access	can	be	controlled	to	allow	users	to	
change	existing	reports	or	delete	them	entirely.	For	the	purposes	of	this	public-access	application,	
allowing	editors	only	to	add	new	features	is	the	desirable	setting.		
	
	
Hidden	field	functionality	was	discovered	through	trial	and	error.	It	appears	that	this	type	
of	behavior	can	be	replicated	when	creating	layers	within	ArcGIS	Online,	although	CGIS	has	
not	experimented	with	implementing	Domains	through	the	online	portal.	
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Quirks	
	
	
	 As	mentioned	previously,	to	properly	set	up	a	hidden	field	that	will	fill	with	a	default	value	
when	a	report	is	submitted,	the	layer	must	first	be	published	with	the	desired	hidden	fields	set	to	
a	Read-Only	value	of	‘Yes’	before	overwriting	that	service	with	the	same	layer	and	the	fields	
changed	back	to	Read-Only	equaling	‘No.’	
	
	 Once	a	feature	layer	has	been	successfully	uploaded	and	implemented	in	the	application,	it	
is	best	to	test	that	the	hidden	fields	are	filling	properly	by	submitting	a	test	report	and	then	
viewing	the	‘Data’	tab	of	the	Item	Details	page	for	that	layer	to	ensure	that	all	fields	were	correctly	
filled.	This	test	report	can	then	be	deleted	or	left	in	the	application	to	serve	as	an	example	
submission.		
	
	 This	method	feels	like	more	of	a	patch	to	obtain	the	desired	behavior	than	something	that	
was	intended	for	final	roll-out	by	ESRI,	and	may	be	invalidated	by	future	updates	to	the	
application.		
	
Report	submission	via	the	desktop	application	is	nearly	seamless,	although	some	issues	
present	when	reporting	via	a	small	mobile	device	(phone	or	small	tablet).	Point	layers	
require	a	single	tap	to	submit,	while	polygon	layers	require	a	tap	at	each	vertex	to	draw	a	
line,	and	then	a	double	tap	at	the	final	vertex	to	automatically	close	the	shape.		
	
	 Reports	will	be	considered	incomplete	and	not	submitted	if	the	user	tries	to	close	the	shape	
by	drawing	the	final	vertex	at	the	same	location	as	the	starting	point.	The	shape	is	not	completed	
until	it	is	filled	with	grey,	meaning	that	a	shape	that	appears	to	be	a	closed	polygon	man	not	in	fact	
be	complete.	Once	a	shape	is	finished,	clicking	or	tapping	elsewhere	on	the	screen	will	start	a	new	
shape,	so	one	must	be	mindful	to	carefully	place	the	first	vertex	if	attempting	to	‘erase’	an	existing	
shape	and	start	a	new	one.		
	
	 When	a	location	is	searched	for	with	the	ESRI	geocoder,	the	map	may	appear	to	zoom	out	
instead	of	in	towards	the	searched	address	or	point	of	interest.	This	happens	due	to	the	fact	that	
the	area	encompassed	within	the	map	extent	is	already	a	fairly	high	level	zoom	compared	to	the	
global	basemap,	and	searching	for	a	location	will	zoom	to	a	relatively	close	proximity	that	happens	
to	be	a	lower	zoom	level	than	is	native	to	the	web	map.	No	options	to	configure	this	zoom	are	
currently	available.			
	
Hosting	the	application	on	an	organizations	web	server	is	not	a	complicated	procedure,	but	
does	require	some	configuration	of	back	end	code	to	fully	duplicate	the	application	hosted	
on	ESRI’s	servers.		
	
	 The	first	step	is	pulling	the	AppID	from	the	ESRI	hosted	application	and	replacing	the	
default	application	code	in	a	downloaded	code	bundle.	Afterwards,	changing	the	splash	screen	
settings	and	image	can	be	accomplished	by	including	the	desired	image	in	the	correct	location	
within	the	code	bundle’s	folder	hierarchy.	Other	images	such	as	logos	and	images	included	in	the	
help	widget	must	be	included	in	the	same	manner.		
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